eclipse mars (4.5) and trouble connecting to subversion

Main menu:

Topics

Recent Posts

Feeds

RSS Feed RSS - Posts

June 2015
M T W T F S S
« May   Jul »
1234567
891011121314
15161718192021
22232425262728
2930  

Past Posts

Java/Java EE

JDBC

Other

eclipse mars (4.5) and trouble connecting to subversion

June 25th, 2015 by Jeanne Boyarsky

Every year, I create a blog post about the latest version of Eclipse. While this post is about Eclipse Mars (4.5), it is not that post. This post is about my troubles connecting to Subversion using Eclipse. Which was unexpected as I’ve never had that problem before.

After installing Subversive, I restarted Eclipse. I then got prompted for installing a SVN Connector. I chose the first one (SVN Kit 1.7). I don’t know what happened; it didn’t work.

Unsuccessful attempts

I then went to the workspace preferences > team > svn and clicked add connectors to get the prompt again. I wanted to choose SVN Kit 1.8. Unfortunately I clicked Javahl by accident. Which of course didn’t work because it I don’t have SVN natively installed.

The error I got for Javahl was at least clear:

SVN: ‘0x00400104: Check HEAD Revision’ operation finished with error: Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are available or install and select pure Java Subversion connector from the plug-in connectors update site.
If connectors already installed then you can change the selected one at: Window->Preferences->Team->SVN->SVN Connector.
Get log messages for ‘https://svn.javaranch.com/svn’ failed.
Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are available or install and select pure Java Subversion connector from the plug-in connectors update site.
If connectors already installed then you can change the selected one at: Window->Preferences->Team->SVN->SVN Connector.

Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are available or install and select pure Java Subversion connector from the plug-in connectors update site.
If connectors already installed then you can change the selected one at: Window->Preferences->Team->SVN->SVN Connector.

No problem. I’ll just go back there and click add connectors again. Nothing. Can’t get pop-up to show up. I unsuccessfully tried restarting. Then I decided to uninstall Subversive entirely and start over.

Uninstalling

I went to help > installation details > subversive and clicked all subversive one. I then uninstalled. This was unnecessary as the problem was a connector. I then did help > installation details > javahl and uninstalled. After re-starting Eclipse, I got the connectors pop-up back.

Third attempt?

The connectors pop-up came back. SVN Kit 1.7 failed again. I then tried SVN Kit 1.8 which gave me an error about there not being any connectors. I restarted yet again and was finally able to connect to SVN. I’m not sure why this worked. I suppose the lesson is to uninstall and keep rebooting until it works?

 

Comments

Comment from RAM
Posted: January 27, 2016 at 1:03 pm

If you go to Window -> preferences ->SVN -> on the main window of SVN, there is a button called “Get Connectors” – This helped me for the similar problem.
Happy coding!

Comment from deep
Posted: June 27, 2016 at 3:37 am

im Getting issue in Connecting with Svn in Eclipse Neon plz guide me and suggest me the procedure to connect.. im not getting the button get connector..

Comment from Jeanne Boyarsky
Posted: June 27, 2016 at 8:33 pm

Deep: Please post your SVN connection question at http://www.coderanch.com/forums/f-12/vc so we can discuss? It’ll require more info/back and forth so the comments section of a blog isn’t a good place for troubleshooting.

Write a comment